Propose new term not working as described

I have been following the instructions diligently for proposing new terms based on existing. I have found the like term in the mapping screen and tried clicking on “propose”, tried right-clicking, tried choosing from the File menu. When I am editing the “new” term, some data is missing. There is nothing for local term, etc. The similar code area is filled in. I make my changes and hit “save”. When I go to “Review and Submit” my proposals are all there but the Test Code column is empty in all cases, as are the next two columns until I get to “component” column. According to the directions, RELMA should have generated a code for the TEst Code Column. I have tried this every way possible and it is not generating a code for me. Is this a problem or should I carry on? I even went back and re downloaded the software to ensure that I had the most updated version. If I open up any of my proposed terms also, the similar code area is now not filled in (even though the info was there when I was editing). I do not want to carry on with all this work if my submission will be denied because of a data entry issue. Please advise. Happy to send a screen shot if you need. Thanks.


I am sorry to hear you are having problems.

Could you please reply with the RELMA version number (found on RELMA’s about screen) and operating system?

I was originally using 6.6 and had the problem but I deleted and redownloaded to make sure I had the most current, so now I am at 6.8 Build5563. I am using Win 7 Enterprise 32-bit. Interestingly, I created my proposals while on the 6.6 version and went to the Review and Submit form and this is when I saw the problem. After I uninstalled the Relma program and installed the 6.8, I thought for sure that I would have to reenter all of my proposed terms (thinking that this form would have been deleted also) , but when I clicked on Review and Submit, they were all still there. I tried deleting just one or two terms and “re-proposing” them based on existing terms and they still showed without the test code and like terms data. Could it be that there is a problem with my “review and Submit” form? I thought that surely this form would be deleted when I uninstalled the program…


Thank you for your response. I have spent the past couple of days re-reading your post and am not able to determine the root problem.

From what I can tell there are two issues (please verify):

    * Absence of test code
    * Absence of like terms data

Unfortunately, this form is very complex and has similarly named fields.

First, can I assume that item 1 is referring to the Local Code Test (OBX-3) field?

Secondly, would you mind being more explicit in terms of like terms data? What specific fields do you think have missing data.

Once again, I am sorry for the confusion.

I’m sorry but I don’t know how to show you a screen shot. On my form “Review and Submit”, the columns that are empty are:


Date Submitted

Test Code

Test Code Description

Assigned LOINC

I understand that it makes sense that some are blank as I have not submitted them yet, but according to the instructions, there should be a randomly generated RELMA#### code in the Test Code column. This is not there.

When I am in the mapping screen, I find my similar term and highlight it. There is no information whatsoever in the whole upper Local Code sections. I click on Propose new term based on this, and the screen opens up. The entire Local code top part of the page is empty except for the “similar LOINC” section-this code and name are filled in but those are the only two boxes. I then go through the section beneath that and edit the information that I want and click on save.

Now I go to my Review and Submit form and, as I mentioned above, all of those spots are empty. I am not sure what should be filled in but my understanding from the instructions is that there should be something in the Test Code field (a number or the random RELMA###). Additionally, if I double click to open up one of my proposals, the ENTIRE top section is now blank, even the Similar LOINC section.

So, to summarize:

When I find my term and click on Propose, the only field that is filled in is the similar LOINC (code and the name). Once I edit and look at my Review screen, all of the above columns are blank. If I double click to open a proposed term from that list ALL fields about the line on the top section are blank. No data at all.Even where the Like Terms data had been while I was editing the term is now blank.

Again, I am not sure if this is a problem or not. If it is fine that they are blank, that’s great. It just didn’t follow the examples in the manual. If it is not OK, I do not want to continue with the submission work without first sorting this out.

If you would like, I can send you some screen shots if you need.




Thank you for your patience and detailed description. What you have found is an oversight on our part. In previous versions of RELMA, we populated the local test code field as a means of uniquely identifying a single requested term. Since that time, we have redesigned the request process and the need to have this code no longer exists. Unfortunately, we did not remove this entry from the user manual. Assuming you do not use this field as part of your workflow, you may disregard this portion of the user manual. If, however, you do use this field, please let us know so we may discuss future design considerations.

In case I have not satisfactorily answered your concerns, I have sent a separate private message to your account that includes my email address. This way, we can make better use of screenshots.

Thank you much,

James Dennis

Thanks very much. I sent you a detailed email with some screen shots. If it is acceptable to submit the form in its current fashion (assuming that I have done everything else correctly in editing the actual term information), please just let me know so that I can know for sure that it is all right for me to continue on.