LMOF3 database swap not working

I have several users working on RELMA in our hospital. When one finished partial mapping on a computer, I copied the LMOF3.MDB file and saved it so that a second user could work on a different local terms set on the same RELMA installation. When the first user came back later, I copied back the LMOF3.MDB file I had saved earlier into the RELMA folder (after saving the current one). I assumed the first user would be able to start back from where she had left. Instead, I got an error message when I clicked on the Map Local Terms button saying “Sorry, but an error has occurred. You may contact…”

Surprisingly, when the copied back the second users’s LMOF3.MDB file back to the RELMA folder, I received the same error message. Now both the maps seem to be lost.

I have tried repairing both LMF3.MDB files using the Access > Compact and repair command; it did not help. Below is an extract from the log file:

2016-06-03 14:18:25,617 [1] INFO DEFAULT [(null)] - ---------------------------------------- 2016-06-03 14:18:25,633 [1] INFO DEFAULT [(null)] - Application Version 6.10.5941.25110 2016-06-03 14:18:25,633 [1] INFO DEFAULT [(null)] - DataHomeFolderPath: C:\Users\Public\Documents\RELMA\ 2016-06-03 14:18:25,961 [1] INFO DEFAULT [(null)] - DeveloperMode: False 2016-06-03 14:18:25,961 [1] INFO DEFAULT [(null)] - Debug Mode: False 2016-06-03 14:18:26,774 [1] INFO DEFAULT [(null)] - 1 changes occurred during schema upgrade. 2016-06-03 14:18:26,805 [1] INFO DEFAULT [(null)] - No changes occurred during data migration. 2016-06-03 14:18:33,768 [1] WARN DEFAULT [(null)] - ProxyAuthenticationRequired 2016-06-03 14:18:39,999 [1] INFO DEFAULT [(null)] - LocalTermChanged to 0, new view model registered. 2016-06-03 14:18:40,592 [1] INFO DEFAULT [(null)] - Initial preferred language id: 9 2016-06-03 14:18:40,592 [1] INFO DEFAULT [(null)] - Initial spell checking enabled value: True 2016-06-03 14:18:40,592 [1] INFO DEFAULT [(null)] - InternetConnected: True 2016-06-03 14:18:47,803 [1] ERROR DEFAULT [(null)] - Regenstrief.Relma.LocalCodeNotFoundException: 0 was not found in the Local Codes grid. at Regenstrief.Relma.LocalCodeTreeViewer.GetRowNumForItem(Int32 id, Int32 Column) at Regenstrief.Relma.LocalCodeTreeViewer.GetNextItem(Int32 CurrentID) at Regenstrief.Relma.FrmMapping.CheckUserNavigation() at Regenstrief.Relma.FrmMapping.frmMapping_Activated(Object eventSender, EventArgs eventArgs) at System.EventHandler.Invoke(Object sender, EventArgs e) at System.Windows.Forms.Form.OnActivated(EventArgs e) at System.Windows.Forms.Form.set_Active(Boolean value) at System.Windows.Forms.Form.WmActivate(Message& m) at System.Windows.Forms.Form.WndProc(Message& m) at Regenstrief.Relma.FrmMapping.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Is there any way I can prevent loss of all the hours of mapping word done by the two users?



Sorry to hear that are having issues with RELMA. The process you describes seems like it should work. However, an easier way to share an LMOF file is described in our FAQ available here.

I can work with you to try to resolve the issue with your LMOF. You can contact me via the RELMA support form available here.



having a problem with the LMOT3, too.

after installing the RELMA i can’t open it successfully, it pops up a window which says “the LMOT database is invalid - it cannot work without a valid database.”

I’ve done reboots and re-installations but nothing helped.

the data are saved in C:.…public\documents.… while the program itself is installed in C:.…\program(x86)

is there a problem that RELMA can’t find the path where LOMT is saved?

how can i fix it?